composer忽略版本运行

composer忽略版本运行

010

今天找了一些php插件,想要使用,结果无法使用

报错大概如下

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - topthink/think-installer v1.0.12 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.3.0] but it does not match the constraint.
    - topthink/think-captcha v1.0.8 requires topthink/think-installer >=1.0.10 -> satisfiable by topthink/think-installer[v1.0.12].
    - topthink/think-captcha is locked to version v1.0.8 and an update of this package was not requested.

You can also try re-running composer require with an explicit version constraint, e.g. "composer require isszz/rotate-captcha:*" to figure out if any version is installable, or "composer require isszz/rotate-captcha:^2.1" if you know which you need.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

找了好多答案,什么更换源啦,什么修改配置啦,大部分屁用没有,因为问题是,版本不对,索性直接忽略版本就好了

所有的命令加一条 –ignore-platform-reqs

完成

© 版权声明
THE END
喜欢就支持以下吧
点赞0
分享
评论 抢沙发
梁大路的头像-梁大路seo

昵称

取消
昵称