Your requirements could not be resolved to an installable set of packages. Problem 1 - topthink/think-installer v1.0.12 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.3.0] but it does not match the constraint. - topthink/think-captcha v1.0.8 requires topthink/think-installer >=1.0.10 -> satisfiable by topthink/think-installer[v1.0.12]. - topthink/think-captcha is locked to version v1.0.8 and an update of this package was not requested. You can also try re-running composer require with an explicit version constraint, e.g. "composer require isszz/rotate-captcha:*" to figure out if any version is installable, or "composer require isszz/rotate-captcha:^2.1" if you know which you need. Installation failed, reverting ./composer.json and ./composer.lock to their original content.